Creating_a_dungeon_in_GIMP,_part_1

zammm
Joined Jul 2003
28053 Posts

Creating_a_dungeon_in_GIMP,_part_1

by zammm, Aug 14,2009
Gimp Tutorial for making maps


Create a New File
1 - Start up Gimp
2 - Create a new file

       File->New; or CTRL + N

Here are the settings that I will be using:
[[Image:http://i39.photobucket.com/albums/e192/mbeau/Making%20a%20dungeon%20in%20GIMP/Tutorial-NewFile.jpg|]]
Click OK


Create a Grid 1 - View -> Show Grid

[[Image:http://i39.photobucket.com/albums/e192/mbeau/Making%20a%20dungeon%20in%20GIMP/Tutorial-ShowGrid.jpg|]]
The default settings has the grid being a bunch of crosses. Nice for drawing, kinda useless for making a dungeon. We need to change this to lines suitable for an (x,y) coordinate grid system.
2 - Image -> Configure Grid
[[Image:http://i39.photobucket.com/albums/e192/mbeau/Making%20a%20dungeon%20in%20GIMP/Tutorial-ConfigureGrid.jpg|]]

3 - Change the line style from Intersections - Crosshairs to Solid
4 - The default spacing for me was 10 pixels apart. On my screen, I decided that was too small, so I increased it to 16 pixels apart. This is entirely up to you. You will probably have to play a bit to find a setting that works for your map.
[[Image:http://i39.photobucket.com/albums/e192/mbeau/Making%20a%20dungeon%20in%20GIMP/Tutorial-GridSettings.jpg|]]

5 - Make sure the image is displayed at 100%. You can double check this by looking at the header of the window. If it is not at 100%, go the lower left-hand corner of the window and set the drop-down menu to 100%.
6 - Take a screenshot. In Windows, the fastest way is to click the Print Screen key on your keyboard. For Macintosh, it comes with a tool that can take screenshots, found in the Application list.
7 - Edit -> Paste as New
8 - Select your Crop Tool. There are three ways to do this. The first is Tools -> Transform Tools -> Crop and Resize. The second is Shift-C. The Third is to use the button on the main Gimp Toolbar.
[[Image:http://i39.photobucket.com/albums/e192/mbeau/Making%20a%20dungeon%20in%20GIMP/Tutorial-SelectingCropTool.jpg|]]

9 - Make sure the window setting is at 100 % and that the entire grid is visible in your window. You may have to expand the window to do this.
10 - Starting at the Upper-left hand corner, click and drag down to the lower right-hand corner. Once you click the button, a window will open up. Ignore it. You will know when you are perfectly aligned with the borders of the grid when the borders of the grid change colours.
[[Image:http://i39.photobucket.com/albums/e192/mbeau/Making%20a%20dungeon%20in%20GIMP/Tutorial-Crop.jpg|]]

11 - Click Crop.
12 - Save the image as a GIMP XCF image.
Cleaning up the grid

1 - Pick the Select Regions by colour tool.
[[Image:http://i39.photobucket.com/albums/e192/mbeau/Making%20a%20dungeon%20in%20GIMP/Tutorial-Selectregionbycolour.jpg|]]

2 - Click inside one of the squares.
3 - Edit - Cut (CTRL + X)
4 - It will look kinda weird, but that is all right, we haven't set a background colour yet.
Adding background layer beneath grid Now it is time to add the background layer that will go beneath the grid.
1 - First you need to select a colour for the underlayer beneath the grid.
2 - Go to the Tool window and click on the background colour.
[[Image:http://i39.photobucket.com/albums/e192/mbeau/Making%20a%20dungeon%20in%20GIMP/Tutorial-Underlayercolour.jpg|]]

3 - Using the options, pick a colour. I am using 6f6363 (the html code) in my example.
4 - There are two ways to add a new layer. Through the Window Menus (Layer -> New Layer) or from the Layers Control Panel. (See red circle)
[[Image:http://i39.photobucket.com/albums/e192/mbeau/Making%20a%20dungeon%20in%20GIMP/Tutorial-NewLayer.jpg|]]

5 - Make sure the Layer Fill Type is set to Background colour, give it a name (I called mine Underlayer) and click OK. Your precious grid just disappeared, but don't worry, it is just hidden by the new layer you put in.
6 - Go to the Layers window, click on the new layer that you just created, and click on the down arrow. Voila, your grid just appeared.
[[Image:http://i39.photobucket.com/albums/e192/mbeau/Making%20a%20dungeon%20in%20GIMP/Tutorial-BringingGridForward.jpg|]]
7 - Save your file.


Thanks to SpaXe for the inspiration and for allowing me to copy his Photoshop Tutorial format.Map Making Tutorial for Gimp - Part 1

Contributors