Character Builder Technical Issues FAQ

49 posts / 0 new
Last post
This will be the FAQ for the Character Builder Beta once it goes live.

Link to Official WotC FAQ

Where can I get the Character Builder Beta??
[indent]From the Character Builder Website.[/indent]
What is this .net I hear being talked about?
[indent].net is a background or framework upon which WotC has built the Character Builder tool. The latest version of .net is 3.5 SP1. You can get it here.[/indent]

I run Windows Vista 64, but can't get the CB to work.
elf;17220947 wrote:
From what I can understand it sounds like it needs to run in x86 compatibility mode. I'm looking into a fix right now from our end. I'll update you when I have more information.

To suggest things to go into the FAQ, please post here.
Mudbunny SVCL for DDI Before you post, think of the Monkeysphere
the solution for x64 mentioned above doesn't work to my knowledge. One person suggested running it in compatibility mode on x64 vista to get around the 64-bit incompatibilities, but everyone I know who has tried that (myself included) has had no success.
Just in case anyone that's reading this is having the 64-bit problem and hasn't seen the 64-bit thread, it can be found here. Also...

On a somewhat interesting side note...

While the beta doesn't seem to work for windows x64, I just got it working using VirtualBox in Ubuntu 8.10 x64 to emulate windows xp 32-bit. The same thing would probably work using the windows version of VirtualBox. It's not an ideal solution, but if you want to get a taste of the Character Generator before WotC releases the x64 fix this should work.

Note: If you get any error messages from the beta while trying this, you probably shouldn't send the report as it might just prolong WotC getting to the issues that the beta has in a normal windows install.

alot of this should be in a technical FAQ, then have a separate CharBuilder usage FAQ (fitting since there are two forums) .
/agree
Will there be a Mac-Friendly option. I see all these people gush about the Character Builder and I feel sad and left out as a result.

I'm running it in Boot Camp with XP, but I'd be very pleased with a web-based version or a Mac-friendly program.
Originally Posted by elf regarding entering custome stats

Just type them in. Click on the box and type in any number you want.

lol. omg, thats brilliant, way easier than what i was doing, which was opening up the save char file and editing the xml directly (which also works)..

next time ill try typing in the box instead ...
I'm running it in Boot Camp with XP, but I'd be very pleased with a web-based version or a Mac-friendly program.

I didn't think I was alone in expecting that the tool was going to come as a web based tool, and not a downloaded one.

I'm just kind of loathed to run boot camp for 1 small app
get virtual box. Much easier and free.
I didn't think I was alone in expecting that the tool was going to come as a web based tool, and not a downloaded one.

I'm just kind of loathed to run boot camp for 1 small app

It's also a huge pain in the neck when all of your files for your D&D game are on the Mac side of the partition and you can't refer to them while using the character builder :-(
BTW, if you didn't see the news, a new installer is out and is much friendlier to 64 bit systems.

Thread here:

http://forums.gleemax.com/showthread.php?t=1112308
EDIT OUT) wrong place to post, sorry.
I don't mean to sound like a broken record on here, but I too as a mac user, feel a bit, ummm, left out here. I don't really have any way of getting windows for boot camp (no way I'm spending money for an OS just so I can run an app), but I am afraid the wizards will possibly overlook or ignore the mac users in its fan base. Magic Online has been out for how long now and there is no mac support for that. Just thought I would put in my two bits.
I'm a Mac user to, but I already own a copy of Parallels Desktop, so I can still use this application without difficulty. I'm loathe to admit it, but PD is just a necessary piece of software for Mac users.

I would have preferred a web-based application, though. In fact, I'm surprised that WOTC went through the trouble of making it a .net application. It would have been easier for everyone if it were a web app. The bandwidth requirements would have been low, and they wouldn't have had to worry about printing support -- just create a PDF.

Of course, knowing WOTC, they probably would have created a web application that works only in IE.
I believe this is in the right spot...

I was making a dwarven Barbarian and noticed when i bought the executioners axe and the dwarven weapon training that on my character sheet it didnt add to Prof of the weapon. my understanding is it does so i was thinking the builder wasnt calculating it right, or am i mistaken?
Anyone know why my computer does not attempt to run the recent patch? Any way to force it to run? I don't even get the screen where it checks for a patch.

I'm on a Vista machine.

Adam
i have a problem with the character sheet fiting on the printed page from the character builder. the right side of the page is missing about a 1/3 of a inch
I see this when printing to PDF but not to physical paper.
Wrong place
Stupid question.  But how large is the character builder file if you download it from scratch, including all the updates?

If you are having problems updating the program, or if it refuses to run and returns an error, chances are it's due to an incomplete or corrupted .NET update. The following steps may fix the problem.


1. Uninstall the Character Builder.
2. Go to Microsoft.com and search for .NET, then download the .NET 3.5 SP1.
3. Install .NET 3.5 SP1. Even if Windows claims you already have it, try to install it anyway.
4. Reboot. Regardless of whether the .NET update looked like it installed or not.
5. Reinstall the Character Builder.
6. Update the Character Builder.

2. Go to Microsoft.com and search for .NET, then download the .NET 3.5 SP1.

.NET is now on build 4. Does that make a difference?

(I tried reinstalling .NET and then reinstalling (as admin) the CB. Still no success.)

Here are the PHB essentia, in my opinion:
  • Three Basic Rules (p 11)
  • Power Types and Usage (p 54)
  • Skills (p178-179)
  • Feats (p 192)
  • Rest and Recovery (p 263)
  • All of Chapter 9 [Combat] (p 264-295)
A player needs to read the sections for building his or her character -- race, class, powers, feats, equipment, etc. But those are PC-specific. The above list is for everyone, regardless of the race or class or build or concept they are playing.
Ignore .NET 4.0. Unlike most programs, a higher version number of .NET is largely incompatible with earlier versions.

 Download .NET 3.5 and .NET 3.5 SP 1. Install 3.5, reboot, install 3.5 SP 1.

Something else that may help is making sure that both the character builder and the character sheet viewer have the appropriate permissions in your firewall to access both "trusted/local" zones and the internet.

Also, make sure both the Character Builder and the Character Sheet Viewer have the same level of permissions; that is to say, make sure they're both set to "run as Admin" in Windows 7.
Whenever I try and launch the CB it instantly crashes and I get the error message (I run Windows 7) that says "This program has stopped working". I tried updating my .Net framework but as it says above 4 won't help and when I did the 3.5 and SP1 it tells me that windows 7 comes with that and I can mess with it in the "Add/Remove Windows components" area and just closes the install.
Considering I can't even launch the web version at this point in time, I am utterly disapointed.  One of the reasons I liked the character builder was so I could use it offline for adventures.  Not everyone has access to an online network during an adventure campaign.  Having to hit this thing online and hope that it will load in a timely manner is ridiculous.  I want the old version back.

All the new version does is tell me the web page is timed out and would I like to relog in and authenticate again.

The new online Character Builder that I am paying for every month doesn't work right (power text is being cut off on the print out so I can't even read what the power does on the power cards), has less features than the one you are taking away (forced to print out and use pencil rather than use electronic char sheet with checks for encounter and daily powers, and editable hit point text fields) and no ability to share my character with me DM. You guys are clueless. Don't release crap and take good things away till the new stuff WORKS and DOESN'T TAKE AWAY IMPORTANT FEATURES. I am seriously thinking of canceling my subscription and just using the old one that works and stop paying for junk that doesn't work (I have had two years of subscription up till now). Fix this or you will lose customers!
In the middle of working on a character and it froze up on me.  Refreshed it and now it doesn't load up anything.

IMAGE(http://www.nodiatis.com/pub/26.jpg)

The character builder seems to not load leaving me with a white screen. I really wanted to finish printing characters for tonights game. 
I can't get it to work either, just a white screen.

I have been getting the white screen for two weeks now. Has anyone seen a fix?
 (running Windows 7 - 64)

I can get as far as the New, Cusom, Load screen but none of the buttons will respond to being clicked. Been this way for weeks. (Windows XP SP3)
Well done folks... Been playing D & D since 1983.... last your I tought my kids 3.5 and got them hooked.  Last Christmas i got them the complete 4.0 books and 2 dungeons.  Now I was impressed with 4.0 and the CHaracter builder you have then.   Now you change up character builder yet again and insist I install Microsoft Silverlight which will not install in my 6month old comp with a fresh OE XP install.... so I can't use the character maker.... after 45 mins of trying to handrole a character with my 15yr old Asbergers Son, I gave up. 

You just lost a 28 year devoted fan.  You need for greed to have all sign for a montly mag was bad enough, and yet you got worse... Moving to new gaming system.  Canceling Subscription, very disappointed, Gary is prob turning over in his grave.

Signed
Tim Crawford
I can get as far as the New, Cusom, Load screen but none of the buttons will respond to being clicked. Been this way for weeks. (Windows XP SP3)



Same over here. Trying to import a charakter, CB does not respond to anything afterwards.

What am I spending my money on? Why did I renew my subscription?

The new character builder is extremely slow loading on my desk top. My experience has found it far less user friendly than the d'l version.

On my lap top, it just doesn’t load at all. Just a white screen.

To make the whole experience even more aggravating there is absolutely no help found here. No one from Wizards even acknowledging there are issues.

(desktop has XP, laptop has windows 7)

Agreed, Never expected this to be as slow as molasses in January (would like to use a more descriptive and accurate phase but don't want the account banned) Yell

You are hauling in money over this, spend it on the servers if that is the problem. If its the programmers, fire their butts for giving you this crap.


What am I spending my money on? Why did I renew my subscription?

The new character builder is extremely slow loading on my desk top. My experience has found it far less user friendly than the d'l version.

On my lap top, it just doesn’t load at all. Just a white screen.

To make the whole experience even more aggravating there is absolutely no help found here. No one from Wizards even acknowledging there are issues.

(desktop has XP, laptop has windows 7)




For the record I have contacted Wizards' Tech Support, but being the weekend haven't received a reply (nor was expecting one before the first of the week).

But I am amazed that they have a forum set up fo tech issues, and others have posted before me with the exact same white screen problem, but no response. And those other posts are a month old.

I have also just discovered another problem. I can't import my characters from the downloadable version. They don't appear in the character builder folder.
Wow... Spooky... Momensts after my last post a response from Wizards Customer Support showed up in my email.

Anyhow, I followed the instructions and character builder works on the laptop now. No more blank white screen.

I was already running the latest versions of ei and silverlight, also the language was already set to English (US). I did adjust the privacy settings but then put them right back to where they were before clicking apply and ok. So, the only thing that might have done it was the deleting coockies and temporary files. I'm not sure what did it exactly, but here is the reply they sent...
---

"It appears that this issue may be due to a problem with the web browser, your operating system's regional settings, or the version of Silverlight that you are using.


The first thing to try is to clear your temporary internet files as detailed in the link below:
Answer Title: Cookies, Browsing History, and Temporary Internet Files
Answer Link: wizards.custhelp.com/cgi-bin/wizards.cfg...


After that, reset your browser's settings to their default and disable any installed plug-ins or pop-up blockers that might interfere with the Character Builder. Once you've completed this, please close and restart your web browser.


Next, ensure that your region settings are set to match the instructions below.


To do this in Windows OS:
1.Open Regional and Language Options in Control Panel.
2. On the Regional Options tab, under Standards and formats, click the "English (US)" setting.


In Mac OSX:
1. Go System Preferences then Language and Text
2.Select the Formats tab.
3.Select United States in the "Format" drop down menu.


To make sure you have the latest version of Silverlight, please visit the link below:
www.microsoft.com/getsilverlight/get-sta...


To try a different web browser or upgrade to the latest version of your web browser, please visit the appropriate link below:
Google Chrome: www.google.com/chrome
Microsoft Internet Explorer: www.ie8optimized.com/IE8
Mozilla Firefox: www.mozilla.com/firefox"
---

For the record, it still takes a while to load, but once it is up  it runs better on the laptop.

I cannot believe I'm saying this, but the Char Builder just stopped working for the 4th time because of the same reason:

Trying to buy a flask...
I was informed that the CB would only allow me 20 characters on their system.

What's up with that?!?
Silverlight crashes every time I print. It takes a rather ridiculous long time to spool and then won't print all of the character sheets (usually just the first two).

Anyone else having similar problems. It seems to have started since the last update to the CB.
I have never not had that problem, and the ridiculousness can not be understated. 1gb of Data to spool, just to get the file to pdf.

*!!!

I thought everyone was having this problem, all the time, but your post makes me think, "just me?"

Best solution I've found is to quit all other applications and start with a clear cache, change print priority and keep fingers crossed...
Sign In to post comments