Cannot download latest playtest packet

This is the first round of packet downloads I've had trouble with lol


Whenever I attempt to log into the playtest site, nothing happens. No moving forward, no error messages. It kind of just looks like the Submit button refreshes the page or something. I've tried logging in with every e-mail address/password I could have possibly used, and I've tried resetting my password, and I've tried creating new accounts. The site hasn't reacted in any way whatsoever. I've refreshed, cleared cache and cookies, and tried two different web browsers.

Has anyone else had this issues, or at least have some sort of workaround? 

Alright, at 9:46 EST Tuesday I was able to log in to the system without any problems using Internet Explorer. I would recommend trying again and if you have the same problem, try using a different web browser.


It is possible that this system suffered from the same problem as the first one, to many people trying to log in at the same time and most people's webbrowsers rejecting the connection because it was taking too long. Also if possible try later in the night to avoid this.  
It won't let me get to the new files. It requires me to go through the sign-up process again and I do so. However, I get an error that says:


There were problems with the following fields



  • Email is already registered to an existing account


Any suggestions?

 

Yes. When you go to the playtest website and it has the create an account options displayed by defualt, look under the submit button for "Have you already created a new sign-up account for this new system?  Sign In." Click the blue hypertext Sign In option. That should take you to the place to log in. It appears Wizards got this backwards. Normally the Sign In option is displayed with a link to the create an account option.




You don't need to go through the sign-up process again. You just need to click the Sign In Link. Hopefully that is the problem that you are having and all will be good now.
Just wanted to update that my problem is persisting. I've gotten e-mails from WotC acknowledging the fact that I've created new accounts and changed passwords, and I've done everything my 10 years of amateur and professional technical support background has led me to possibly believe would solve this problem. But the login site has no reaction to me whatsoever.
I'm having the same issue. Won't let me change my password and says the account is already in use. Dumb.

The support people say they can't reset it because it's done by a third party. Still waiting to see if I can contact the third party directly.
Hey gang. First off a tiny bit of clarification. In August we started using a new download system for the playtest packet, and you needed to sign up for a new playtest account to access the playtest. Now, if you created that new account in August you shouldn't have to create a new account to get this packet, but instead login using the same info you entered when creating the account in August.

The existing sign in can be tricky to find for some people, and I've seen a few have issues because they go to log in using the fields for creating a new account. Just to be clear, here's an image with some lame arrows pointing to where you need to go for existing logins:


 


This definitely doesn't solve all the issues, but I have seen a few people make this mistake. I even did it the first time I returned to the site and skimmed through it.

Phaedran, WotC_Josh has recently contacted you so he can help you with your issue. Sakaki22 and anyone else who is still having an issue, please contact customer service. I just finished talking with Josh and others about this and they want to make sure you end up with that packet and with a working login for the system.

Trevor Kidd Community Manager