MTGO Beta Client Autodownloaded and Installed Itself

2 posts / 0 new
Last post
Earlier today, I started and played a match of MTGO just fine. A few minutes ago, I clicked the same shortcut to launch the game. A window came up saying required updates were installing. After they installed, the game started up looking very different - it had a big "Beta" tag on it. I tried to log in (my username was still there from the previous time I used MTGO), but it said I don't have access to the beta server. If I go into the WotC folder in the Program Files and launch "renamer.exe", the old client loads. What gives?

Tried looking on the MTGO site and in the forums, couldn't find anything about this besides the "sneak peek" stuff that happened in July. 
Same problem here.

After i read the article about Mtgo New CLinet Wide Beta i started the client, auto-updated, and after that i introduced the password but it said No acces to the beta server.

This is odd because i did used the new client in the SneakPeak Weekend and it worked fine.

I also tried the old client wich works fine.

 
Sign In to post comments