Can't Sign In to DDI from my Home Computer

5 posts / 0 new
Last post
I can sign in to my account from my Android tablet and from my work computer, but not my home computer. When I click to sign in to DDI, nothing comes up to let me type in my user name and password. This changed around the time of the website update. I have enabled popups from Wizards. I have the newest version of Java and it is enabled. 

Anyone else have any ideas?

Thanks.  

Hi,

 I have the same problem. Started at the same time the new website went up.


Any ideas?

Regards  

Hi,

 I have the same problem. Started at the same time the new website went up.


Any ideas?

Regards  

Since it doesn't appear that they have any plans to fix this, or even address it... there IS a back-door work around.

Log out, and back in to the forums, then go back to the main DDI page and you will now be logged in.  It's a pain in the butt, but it works. 
I can sign in to my account from my Android tablet and from my work computer, but not my home computer. When I click to sign in to DDI, nothing comes up to let me type in my user name and password. This changed around the time of the website update. I have enabled popups from Wizards. I have the newest version of Java and it is enabled. 

Anyone else have any ideas?

Thanks.  

Have you contacted Customer Support about this yet? They would be your best bet at getting a resolution.
AsmodeusLore D&D Insider News Guide Follow Me


D&D Home Page - What Class Are You? - Build A Character - D&D Compendium

I can sign in to my account from my Android tablet and from my work computer, but not my home computer. When I click to sign in to DDI, nothing comes up to let me type in my user name and password. This changed around the time of the website update. I have enabled popups from Wizards. I have the newest version of Java and it is enabled. 

Anyone else have any ideas?

Thanks.  

I was also having this problem on several computers in my house and different browers. My friend noticed the webpage was failing to load some javascript and it was because I was blocking *googlesyndication* on my router. Once I removed google syndication from by blocked list it worked! The forum login doesnt use javascript.

Make sure you don't have googlesyndication blocked in some way, browers add-on, OS firewall, etc.