Bought 3 months of DDI but still can't access the character builder

28 posts / 0 new
Last post
I finally decided to bite the bullet and see if D&D Insider was worth the money.  I signed up for a 3 month subscription, paid for it with Paypal, my account info shows that I have an active subscription...

But when I try to launch the character builder, it just keeps prompting me to subscribe.   I've tried logging in and out, double and triple checked that my account shows an active subscription, but.... nothing.

Any help?  Am I missing something obvious?

Thanks,

Todd

EDIT: Okay, apparently it just takes awhile for the system to recognize the active subscription.  It is working now. 
Thanks for posting the edit. I was doing the same thing as you. 
Was just wondering the same. No email saying as such, and if it was mentioned in the subscription process it wasnt anywhere obvious.

Why does it take time anyway? At most i would have expected a couple of minutes but its been over an hour. Is the hamster wheel powering your servers in need of greasing?

Well so much for a quick pick up to add a friend to this session were about to run, maybe he can take the role of some of the NPCs or something.
Getting your subscription activated can take anywhere from a few minutes to several hours to over a day.  I have no idea why, but that's how it is.
D&D Next = D&D: Quantum Edition
They still haven't fixed it. They really ought to, because I nearly rage-unsubscribed and demanded a refund. It took several increasingly specific Google searches just to find this dang thread. Going on several hours now too... 

Did anyone ever find any notification of this in the subscription process? I sure didn't. 
I'll bide my time and wait before demanding a refund. I have paid for a service, not to be given at a later date, but to be rendered when payment was accepted. It is ridiculous that I suddenly had compendium access but the rest of the tools still, after half a day of basically wasted subscription time, insist I should get DDI. So much for being hailed as a "time saver" =/
I just subscribed myself and am waiting........ Frustrating!!! Its one thing to wait wile somthing downloads but to just wait till the system decideds to give me access after paying for a service is annoying. It should at least say it may take X amount of time for your subscription to activate so a person knows what to expect. Like the man several posts above I almost unsubscribed but I'm waiting....With a tool this well used bugs like this shouldhave been delt with already.
I'm having the same excat problem, I sent them an email. I have never heard of not getting a product with in seconds after subscribing to it.
I have never heard of not getting a product with in seconds after subscribing to it.


Never subscribed to a newspaper or magazine, huh?
Waiting also...ridiculous considering, as others have mentioned, they took my money right away! 
Agreed, I'm having the same issue. I contacted customer service, who said they'd refer it to the proper team and get back to me. It's been 2 days since I subscribed and I have no access to Insider services.

I'm also somewhat appalled that it would, under regular circumstances, take them up to 24 hours to grant access. I realized I sound like an entitled brat, but we should be granted near-immediate access to services after subscribing. It's how most other systems work, and some of them are far more critical than DDI.
I'm going on 4 days since they sent my order confirmation email, and still no access to the character builder.  I'm talking 4 buisiness days here, and now that it's the weekend it seems unlikely anything will happen until Monday.  I sent them an email after the first day and I haven't had any response to it.  If this is the type of customer support they provide, I'm not sure I'll be giving them any more of my money.
Yeah same boat here, just waiting to see the little red dragon on my forum icons... zzzzzz.

Pretty **** how long you have to wait sometime

WHYYYYY 
I just joined and I'm having the same issue... I wanted to use the character builder for a campaign I am in tonight... doesn't look like that is going to happen

Not to mention, I have to sign up for a "help" account? Are you kidding? Bought a year subscription. If I payed for my product, I WANT MY PRODUCT. If you can take my money, you can provide me with the services agreed upon.

I've got the little red dragon icon, but no content access myself.  Digital River said they finished processing the payment, the problem is on WOTC's end.

I'm playing tomorrow night, if it isn't running by then I'll call Visa and cancle the charge.  Amazon and Apple have figured out how to deliver digital content in second after I pay for it.  WOTC should call them if they can't figure it out.  

And CUBPHILDND - I guess you haven't subscribed to a newspaper recently.  Washington Post's paywall comes down instantaniously when you pay them.  So you're both wrong, and jerk.

Just bandwagoning here, but I'm in the same boat. Really disappointed in Wizards here.

I'm having the same issue...  I've never had a problem with Wizards of the Coast till now.

Some of my friends subscribed today and got access to all the tools imediately.

 

I'm going on a week with no access after paying for a year's subscription.

 

Whisky Tango Foxtrot.

What the hell is going on with my subscription.  I am in date financially but the Character builder is badly broken.  Either fix it or give me my money back. 

Just FYI for folks in the same boat, after waiting a week and getting no response to either online tickets or emails to dndinsider I found the phone support line in (of all places) the contact us page here:

 

http://company.wizards.com/contactus

 

Why I didn't think to try that first I can't explain, but it was a quick call, and after providing my account details (email, name, zip, security question answer) my account was granted access immediatly. 

 

Some folks have had to wait up to an hour for access after creating an account, and others have noted that trying a different browser, or logging out then clearning your browsers cache/cookies before logging back in allowed them access after 30 minutes to an hour from subscription.

 

TL;DR: Wait an hour after subscribing, then call the phone support line on http://company.wizards.com/contactus

 

 

Google Play, Amazon, Origins, EA, Ubisoft, Gamefly, Matrix Games, Gamefly, and myriad other companies have figured out how to give you access to your purchases instantly, at this point it's not rocket science.  You'd hope that a company with the financial resources that Wizards has could spare a little cash to fix what is an obvious problem.   

 

Luckily for me, I don't have anything major planned where I need this *now*, but it's still an inconvenience.  I can sympathize with the folks that did need it right away, though.  

You knew the job was dangerous when you took it, Fred.  

Same  rediculous waiting time here too. 

 

Also, I can't be the only one who thinks the site is somewhat clunky and hard to navigate? To exit the forums to go back to trying the character creation I'm now resorting to having several tabs open, if there are any links between, I can't see them.

 

Disapointing, Wizards. You can do so much better.

Sorry to necro, but this is STILL HAPPENING.     

 

FUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUu

------Zero

and another necromancer here, I am experiencing the same issue, it's been 12 hours now and my subscription isn't active yet

Roughly a day and a half later it started working

CUBPHILDND wrote:
I have never heard of not getting a product with in seconds after subscribing to it.

 


Never subscribed to a newspaper or magazine, huh?

 

I know this is old, but terrible analogy. If I subscribe to the digital New York Times, I get it as soon as it finishes downloading to whatever device I do it with. There is no reason (other than payment hangups) for an automated, digital subscription to take more than an hour to activate.

 

well this is irritating. I pid for my subscription 4 days ago, and i still can't access my dnd insider acount. any thoughts?

 

well this is irritating. I paid for my subscription 4 days ago, and i still can't access my dnd insider acount. any thoughts?

 

Sign In to post comments