lost access to subscriber only content (Dragon & Dungeon magazines)

9 posts / 0 new
Last post
I confirmed by phone that my subscription is still active, but I don't have access to the subscriber only content on Dragon or Dungeon magazine anymore.  the links are greyed out and inactive.

Who do I call about this?
I confirmed by phone that my subscription is still active, but I don't have access to the subscriber only content on Dragon or Dungeon magazine anymore.  the links are greyed out and inactive.

Who do I call about this?


Try logging fully and completely out of the site and close all browsers.  Reopen and log back in.
Links greyed out?

Click on the archive link.

I have to do this pretty much every time. About one in every five times I load the Dragon or Dungeon site are the links not all completely greyed out.
The archive link doesn't have the current issue in it, and i don't have access to all of the archive material either

Yes I've tried cleaning out the cache and logging out and back in.


It might help if you told us what browser you are using as well.  I know that IE gives people fits at times and imho it is highly recommended to not use IE.
If you go the archive link and sort by date, it does have the current issue (404 at the time of this post) including new articles. I actually find articles here before the announcements on the forum quite often.
Firefox 7.0.1

I did these screen shots just now from my web browser.  So how do I access the "Runepriests" article if the main page link it grayed out, and the article doesn't appear in the archive?

This is the Dragon main page as I see it



And this is the dragon archive as i see it.  This is the first page


Firefox 7.0.1

I did these screen shots just now from my web browser.  So how do I access the "Runepriests" article if the main page link it grayed out, and the article doesn't appear in the archive?

This is the Dragon main page as I see it


The table of contents (first screenshot) is posted just before the first of the month.  The articles are published throughout the month and become active (black) as they are put up on the site.  What you are seeing is expected behavior with the exception that two articles have issues: "A Matter of Honor" and "Secrets of the Ninja" both appear in the archive and not active in the ToC.  Checking the links in the archive it seems that the ToC is what's in error as the articles are up for those two articles.  If the rest of the articles are not up by the end of the month, then you have a gripe.  If they appear in the archive, but not in the ToC as the above two articles, then you have an error on their site which is easy to fix.

The table of contents (first screenshot) is posted just before the first of the month.  The articles are published throughout the month and become active (black) as they are put up on the site.  What you are seeing is expected behavior with the exception ...



Really?!  I'm embarrassed that I took more than a year to notice this.

Thanks!