Can't select powers

18 posts / 0 new
Last post
I can't select powers during character creation or with imported characters.

All I get is a blank drop-down menu, at the point which I suppose is for power selection. I never even actually seen the thing. 

It does not matter which browser or OS, I get the same result. Tried it with Chrome, Safari and Firefox on Mac, Chrome and IE8 on Windows.

And I've tried it on two different computers, on two different locations.

Same thing is happening to a friend of mine. As I have not seen this subject brought up by others on this board, I was wondering: we both connect from France.

Does WotC have something against us Frenchies ?

I'm also trying to report the bug, but the link seems broken.
Same Problem. French too
Hello all,

I just wanted to add that I have the same problem, and I'm french too (yay !).
This is strange because every other choice works well (feats, etc...) and I also noticed that I can select thief (rogue) tricks, but power selection is impossible with all the other classes that I tried (and retraining too, so there's no way around that). 
Same issue, although I'm Swedish.

Hello all,

I just wanted to add that I have the same problem, and I'm french too (yay !).
This is strange because every other choice works well (feats, etc...) and I also noticed that I can select thief (rogue) tricks, but power selection is impossible with all the other classes that I tried (and retraining too, so there's no way around that). 


For me it seems to work with any Essentials class, except the mage. When I try to bring them to level 2 I get the blank drop down menu again.

So the problem seems to be linked to the drop down menu, somehow. When it's not there I have no issue.
The same  problem! But it happens when I try to create non-Essential character.

Familiar symptoms! When I create a base DnD, Forgotten Realms, Ebberon or Dark Sun hero, i can't choose any Powers. There is no menu options under 'Choose N Powers', or big green 'Choose a Power' buttons under 'Select Powers' section.
Button 'Choose All for Me' works, after clicking it, green 'next' button appears. But no Powers are shown.
In 'Character sheet' mode Character Builder shows filled in character sheet, including chosen Powers. The problem is that it wasn't me who chose them, and I can't choose nor change Powers.

Also I'll break you paranoia, because i live in Russia.
Playing around with the Builder, the drop-down menu seems to be the issue. Essentials Thief At-Will, Warlock Pact At-Will, and such appear normally.

Is the whole of Europe not allowed to choose powers ? Or all non-US customers ?
+1 
Can't see/choose any powers.
Tried two diffrent creation in "home campaign".
 
(can't import either ... an error message is always showing, asking me to refresh/reload)
 
I have the same problem on a Swedish WinXP machine, and have reported it as a bug to WotC. It seems to depend on the regional settings.

A work-around that works for me is to:
1. Find where you can change the regional settings in your OS version, and make a note of your present settings.
2. Change your regional settings to "English (US)" or whatever is the corresponding US English setting in your language. (For me it was "Engelska (USA)".)
3. Then restart the Character Builder.
Result: You can select powers.

When you are done using the CB, you should probably change back to your old regional setting.

To change number, currency, time, and date settings on Windows XP:
1.Open Regional and Language Options in Control Panel.
2. On the Regional Options tab, under Standards and formats, click the locale whose date, time, number, and currency format you want to use.
(instructions from Microsofts support pages).

This is of course just a temporary work-around, not a good permanent solution.

I hope this helps you somewhat!
Wow! Changing regional setting really helps! Thank you, ErikN!
That did it !

For those on a Mac, here's what you need to do:

- Go to System Preferences -> Language & Text
- Select the Formats tab
- Select United States in the 'Format' drop-down menu

This is for OS 10.6, I haven't any older systems available, but it should be the same.

And there you go !

Many thanks, ErikN
ErikN, you're a computer WIZARD. Thank you very much !
I still hope that the developers will notice the problem, because switching languages each time the Builder is activated could be a bit tiring... 
The Level 2 Rogue Utility Power Sudden Jump (or Leap?) is not available in the drop down menu to select.

I reported it as a bug.
- Rico
I had the exact same issue as the OP. I live in Finland. Seems to be a non-US issue, or at least non-english issue.

Even if it works with a different region code, I don't really approve of the program not working without jumping through extra hoops.

WotC, please FIX THIS!
I have the same problem as you, I run Swedish Windows 7 64-bit version. I reported it as a bug to WotC several days ago, they answered that it was a know issue, but still, almost a week later, nothing has changed.

I thought that the new web based builder was made so that they could update and bug-fix it all the time, but as always, they don't care about their non-US customers. I'm not surprised.
Just a note, it's a year later and this issue is STILL not fixed (at least for South Africa).

prestickninja wrote:
Just a note, it's a year later and this issue is STILL not fixed (at least for South Africa).

 

And it's still not

 

My Character builder worked fine until this week when I upgraded from XP to Windows 7. Now on NONE of my browser's can I select any powers.

 

If anyone has any idea how to fix this, please post here

Well, I've got it to work. In a fashion.

I found a program called 'windows virtual PC'. It basically allows you to run two OS's at once. So if you make that run XP then the builder works fine.

 

Hope this helps anyone else who encounters this problem

Im Brazilian and Im having the same problem, gona see if changing the regional settings will work for me.