Character Builder not loading - Blank White Screen

13 posts / 0 new
Last post
Ok I tried Customer Service, but they are no help.

I recently rebuilt my Windows 7 Enterprise work machine and installed Silverlight 5.  Now when I launch the CB I get a blank white screen and nothing else happens.  I've tried letting it sit hoping it was downloading the app, but it never does anything.  Right clicking on the frame brings up the Silverlight context menu, but no CB.  I get a similar issue with Adventure Tools, but the screen is all black.

Anyone know how to resolve this?  I followed the CS suggestions of clearing the Internet cache (even though the OS build is brand spanking new), and uninstalling and reinstalling Silverlight.  Any other suggestions would be welcome.

Also I am using Internet Explorer 9, and I have tried using Compatibility View, but that does not help.  Google Chrome does the exact same thing.

Thanks in advance.     

Kalex the Omen 
Dungeonmaster Extraordinaire

Wow!  Apparently the DDi tools are not compatible with Silverlight 5.  Anyone having problems of this sort can download Silverlight 4 here.

Kalex the Omen 
Dungeonmaster Extraordinaire

I am having the exact same problem, except that reverting to SL4 didn't solve it for me. I've been in contact with Customer Service but their suggestions aren't working. All other SL sites I've visited work perfectly.

Anybody else still having this problem?
Sheeeesh, I get Silverlight's "White Screen of Death" pretty constantly around here, even in different PCs and through different web providers. I'm always lucky when if the CB decides to work when I actually need it ¬¬.
Are you threatening me master jedi? Dungeons & Dragons 4e Classic - The Dark Edition
Uninstalling Silverlight 5 and installing version 4 worked for me! Thanks for the suggestions.
Darth Frodo
I have the same problem too. The ideas from support didn't help. I also tried several different browsers, but all have the same problem showing an empty white window.

I think Wizards just don't care, because they already have our money.
I'm having the same problem, except I was running version 4 and it wasn't working. I updated Silverlight to version 5 and it still isn't working. I'm going to try uninstalling and going back to version 4, though I'm not hopeful.

Is this a known issue?

EDIT: So, that didn't work. However, I ended up clearing my cache and now it is working.
I tired downgrading to Silverlight 4 and clearing my cache, but I get this error with the loading screen:

System.ServiceModel.CommunicationException: [HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See ---> System.Net.WebException: [HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See ---> System.Net.WebException: [HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See
   at System.Net.Browser.BrowserHttpWebRequest.InternalEndGetResponse(IAsyncResult asyncResult)
   at System.Net.Browser.BrowserHttpWebRequest.<>c__DisplayClass5.b__4(Object sendState)
   at System.Net.Browser.AsyncHelper.<>c__DisplayClass4.b__1(Object sendState)
   --- End of inner exception stack trace ---
   at System.Net.Browser.AsyncHelper.BeginOnUI(SendOrPostCallback beginMethod, Object state)
   at System.Net.Browser.BrowserHttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelAsyncRequest.CompleteGetResponse(IAsyncResult result)
   --- End of inner exception stack trace ---
   at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result)
   at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result)
   at System.ServiceModel.ClientBase`1.ChannelBase`1.EndInvoke(String methodName, Object[] args, IAsyncResult result)
   at WotC.ContentManagement.ContentVaultService.ContentVaultServiceClient.ContentVaultServiceClientChannel.EndGetOfficialContent(IAsyncResult result)
   at WotC.ContentManagement.ContentVaultService.ContentVaultServiceClient.WotC.ContentManagement.ContentVaultService.IContentVaultService.EndGetOfficialContent(IAsyncResult result)
   at WotC.XAMLUtilities.GeneralHelpers.<>c__DisplayClass14`2.b__13(IAsyncResult ar)
   at WotC.XAMLUtilities.GeneralHelpers.<>c__DisplayClassd`1.<>c__DisplayClassf.b__b()
I am getting the blank white page too. This is ridiculous. Using Silverlight to create a web app is extremely stupid. The old executable CB worked about a million times better.
Getting the Blank White Page of Doom myself - was on Silverlight 4, tried upgrading to 5, tried in Firefox 10 and IE 7 (with separate caches I might note), tried flushing my Silverlight cache but by that point I was on 5 so it wasn't going to show immediate results I guess. I'm going to try downgrading back to 4, purging everything, rebooting and trying both browsers again. Back in 10 or 15 minutes.
Downgraded to Silverlight 4.1.10111.0 from the link provided above (, cleared my browser cache, cleared the silverlight cache (right click on the blank white window of doom, last tab, pick the character builder, pick delete button), and it's now working again.
I had this problem with Firefox, but fixed it by clearing the cache.

Firefox->Preferences->Advanced->Network->Offline Storage (Clear Now)
I had this same issue on firefox 9.0.1 (I can't upgrade FF becuase of compatability issues with other webapps). Uninstalled/reinstalled Silverlight from the above link, and that didn't fix the issue. However, opening the CB in Google Chrome worked fine for me. Firefox still doesn't work though.
Sign In to post comments