Warning: Character Builder Broken on Silverlight 5 - Deleting characters

36 posts / 0 new
Last post
Just as an FYI, if you upgrade to Silverlight 5, the character builder WILL break. It will constantly give you errors that start "Something went wrong" and if you are very unlucky, it will delete your character if it encounters such an error while loading. The Monster Builder seems broken as well - the "edit power" button causes the whole app to go black.

Downgrading does work, and you should be able to go to www.silverlight.net/downloads and check under the heading "Silverlight 4 (Previous Version)" to get the SL4 update. But be aware, as Silverlight updates automatically. So if you computer is SL4 right now, unless you need SL5 to access a new app (or for development, like me) then try to avoid updating. You can turn off automatic updating by go to the Silverlight properties. (Right click any silverlight app and click "Silverlight")

If, by some chance anyone at Wizards is reading this, you can actually target silverlight apps for a specific silverlight framework. All I think it requires that the developer upgrade to SL5 and then recompile the app, setting the target framework in the project. Actual dev effort on it should be very small. Or at least that should be something that you can determine quickly.
 
On an related note, it's incredibly frustrating that these tools are in such poor shape. If they don't want to keep maintaining these tools, why don't they focus on creating a great API, and just become a service that people pay for? It seems like that benefits everyone. 
 
Ah well. Anyway, I just wanted to warn the other forum readers. Hopefully Wizards will fix these severe, crashing, data deleting bugs in the DDI tools before too long.
[Edit: Added some solutions discussed below.] 
Just as an FYI, if you upgrade to Silverlight 5, the character builder WILL break. It will constantly give you errors that start "Something went wrong" and if you are very unlucky, it will delete your character if it encounters such an error while loading. The Monster Builder seems broken as well - the "edit power" button causes the whole app to go black.

I saw elsewhere in the forums that downgrading works. But be aware, as Silverlight updates automatically. So if you computer is SL4 right now, unless you need SL5 to access a new app (or for development, like me) then try to avoid updating.

If, by some chance anyone at Wizards is reading this, you can actually target silverlight apps for a specific silverlight framework. All I think it requires that the developer upgrade to SL5 and then recompile the app, setting the target framework in the project. Actual dev effort on it should be very small. Or at least that should be something that you can determine quickly.
 
On an related note, it's incredibly frustrating that these tools are in such poor shape. If they don't want to keep maintaining these tools, why don't they focus on creating a great API, and just become a service that people pay for? It seems like that benefits everyone. 
 
Ah well. Anyway, I just wanted to warn the other forum readers. Hopefully Wizards will fix these severe, crashing, data deleting bugs in the DDI tools before too long.

Thanks for the heads-up.  It's always a good idea not to immediately jump to the shiny new version of software as soon as it's released and instead just wait, do your research and make sure it's going to do what you want before upgrading.  I never allow any software to automatically update without getting my approval (except antivirus, and I've even been burned on that once).  It's just good common sense for any software.

I won't update to SL5 until I'm reasonably sure it won't wreak havoc with my CB; I have no need to update it for anything else right now.

Also, you may want to check the system requirements for browser/OS compatibility before choosing to update:

www.microsoft.com/getsilverlight/Get-Sta...

OD&D, 1E and 2E challenged the player. 3E challenged the character, not the player. Now 4E takes it a step further by challenging a GROUP OF PLAYERS to work together as a TEAM. That's why I love 4E.

"Your ability to summon a horde of celestial superbeings at will is making my ... BMX skills look a bit redundant."

"People treat their lack of imagination as if it's the measure of what's silly. Which is silly." - Noon

"Challenge" is overrated.  "Immersion" is usually just a more pretentious way of saying "having fun playing D&D."

"Falling down is how you grow.  Staying down is how you die.  It's not what happens to you, it's what you do after it happens.”

Just as an FYI, if you upgrade to Silverlight 5, the character builder WILL break. It will constantly give you errors that start "Something went wrong" and if you are very unlucky, it will delete your character if it encounters such an error while loading. The Monster Builder seems broken as well - the "edit power" button causes the whole app to go black.

I saw elsewhere in the forums that downgrading works. But be aware, as Silverlight updates automatically. So if you computer is SL4 right now, unless you need SL5 to access a new app (or for development, like me) then try to avoid updating.

If, by some chance anyone at Wizards is reading this, you can actually target silverlight apps for a specific silverlight framework. All I think it requires that the developer upgrade to SL5 and then recompile the app, setting the target framework in the project. Actual dev effort on it should be very small. Or at least that should be something that you can determine quickly.
 
On an related note, it's incredibly frustrating that these tools are in such poor shape. If they don't want to keep maintaining these tools, why don't they focus on creating a great API, and just become a service that people pay for? It seems like that benefits everyone. 
 
Ah well. Anyway, I just wanted to warn the other forum readers. Hopefully Wizards will fix these severe, crashing, data deleting bugs in the DDI tools before too long.

Thanks for the heads-up.  It's always a good idea not to immediately jump to the shiny new version of software as soon as it's released and instead just wait, do your research and make sure it's going to do what you want before upgrading.  I never allow any software to automatically update without getting my approval (except antivirus, and I've even been burned on that once).  It's just good common sense for any software.

I won't update to SL5 until I'm reasonably sure it won't wreak havoc with my CB; I have no need to update it for anything else right now.

Also, you may want to check the system requirements for browser/OS compatibility before choosing to update:

www.microsoft.com/getsilverlight/Get-Sta...

Yeah in order to develop for Silverlight 5, as I mentioned I was doing, you have to download Silverlight 5. The worst part though is that I can't ask anyone I know who uses the CB to test my RPG related app, because then it would break the CB for them. And I can't install it on my laptop where I would actually want to use it because then the CB won't work on my laptop.


I guess after I get done, I'll have to see how difficult it is to port to WP7.
Yeah, just lost my 23rd level character to this exact issue. If the character builder is not compatible with Silverlight5, why does the program prompt users to install the new version when launching the builder? Or is it just Silverlight doing this? Why are we using this plug-in again? I know it is required, but surely something that works would be preferable. 
Yeah, just lost my 23rd level character to this exact issue. If the character builder is not compatible with Silverlight5, why does the program prompt users to install the new version when launching the builder? Or is it just Silverlight doing this? Why are we using this plug-in again? I know it is required, but surely something that works would be preferable. 

Basically it checks to see if your version is equal to or later than the version it needs. If it isn't, it sends you to download the latest version. This is pretty standard plugin behavior. After all, if you don't have the right version, the app won't work at all. There's ways to specifically find the version you need ... But I'm afraid I don't know them off the top of my head, so you'll have to google that one. You're probably looking for 4.0.9 something. I think that was the last 4 version, and I believe that's the one the site requires.

But this is why I cautioned to be aware of the fact that SL can automatically update. In fact, if you go into the Silverlight settings, there is an option to check whether or not it does automatically update. 

On a side note, the Silverlight plugin is not to blame here. Many sites use it to great effect. (Netflix, for instance, works great on my machine.) But no tool can sit unmaintained and continue to just work indefinitely - especially web tools. The web environment changes too frequently for that to be the case. Sadly, it looks as though either money or effort toward the DDI tools just isn't there. Considering the state of the economy and industry, I'm guessing it's the former more than the latter.

Per WotC customer support: There is currently no fix for this issue; characters lost due to this error are not recoverable. 
Per WotC customer support: There is currently no fix for this issue; characters lost due to this error are not recoverable. 

Wow. 

Not surprised it's not recoverable, but they didn't even say that workaround was to downgrade to SL4? Like, they don't read the forums at all? Yikes.

Oh well, at least they responded. They didn't even ever get back to me XD     
Downgrade to Silverlight4 how? It appears to have entered the witness protection program. I have been searching the net for a copy of the install for  4 and now have 6 copies of the SL5 install. It is all MS appears to offer, even though they have stated Mac support ended in 2010. I got a response from MS tech support, but the tech read my question and concluded that I am having trouble getting the SL5 install to proceed. I am not; I installed it and found it to be an utter steaming loaf that destroyed a data file I have been working with for a year and which I have no way to replace. I sent another e-mail stating that my only question about SL5 is how to go back to SL4. 

I will give it a week. If it isn't fixed I am just going to cancel my subscription; no way I am going to continue to pay for a character builder I can't use. 
Downgrade to Silverlight4 how? It appears to have entered the witness protection program. I have been searching the net for a copy of the install for  4 and now have 6 copies of the SL5 install. It is all MS appears to offer, even though they have stated Mac support ended in 2010. I got a response from MS tech support, but the tech read my question and concluded that I am having trouble getting the SL5 install to proceed. I am not; I installed it and found it to be an utter steaming loaf that destroyed a data file I have been working with for a year and which I have no way to replace. I sent another e-mail stating that my only question about SL5 is how to go back to SL4. 

I will give it a week. If it isn't fixed I am just going to cancel my subscription; no way I am going to continue to pay for a character builder I can't use. 

Alright, I can't guarantee that this will work because I haven't tried it myself:

Uninstall Silverlight. You should be able to do this through Control Panel > Programs

Go to this link: go.microsoft.com/fwlink/?LinkID=149156&v...

That specific download of Silverlight (it'll still just be called Silverlight.exe) should be the last v4 that was released. Then I suggest the very first time you load up the character builder, right click on the App, click "Silverlight", click "Updates" and check "Never check for updates" haha

You know the worst part? According to Microsoft this takes literally no development time at all to fix. Wizards can still target SL4, they just have to recompile their project and set it to target SL4, then redeploy. That's it. It would take 5 seconds + build time + deployment time. I mean, provided they have a hotfix branch of their source code. One would hope.

Anyway, hopefully that works. If it doesn't ... then yeah, you will probably not be the first person to cancel their sub over this. 
Uninstalling V5 was as simple as dragging the plugin to the trash. It is in /library/internet plug-ins.

The problem is there is no V4 to be found to reinstall. It isn't available to download. Clicking on any download or install button on the MS site invariably leads to downloading the V5 installer. I will wait and see if I get another response, but Microsoft doesn't generally make older versions of their products available because doing so admits that there might be beings on this planet who find fault with the current version.  
Uninstalling V5 was as simple as dragging the plugin to the trash. It is in /library/internet plug-ins.

The problem is there is no V4 to be found to reinstall. It isn't available to download. Clicking on any download or install button on the MS site invariably leads to downloading the V5 installer. I will wait and see if I get another response, but Microsoft doesn't generally make older versions of their products available because doing so admits that there might be beings on this planet who find fault with the current version.  

So the link I posted doesn't go to a download or install button. It's a GoLink that links to a specific Silverlight version. And actually, all of the old Silverlight versions are still available at their respective golinks.


I didn't realize you were on a Mac though. (That does explain some of the animus XD) Have you tried clicking that link? I think it does an OS check before sending the file. Here is the link again: go.microsoft.com/fwlink/?LinkID=149156&v...


Again, that's a link to Silverlight v4.0.60310.0 specifically. Hopefully that will download the Mac plugin.  
I just went to the silverlight main page and got v4...www.silverlight.net/downloads
Tech support at Microsoft says MS does not supply older versions of its software, but gave me a link to Cnet. I don't know why I didn't think of that earlier; Cnet has archives of downloadable software and they never seem to clean any of it out. I found and installed SL4.x. And it appears to work, with Chrome, Firefox, and Safari. 

Of course, my character was still permanently deleted, but I re-rolled using my most recent paper copy.

I will never upgrade to SL5 even at gunpoint. There is no other web service I use that requires it, there is nothing on its feature list that is not in 4 that I need, and using an old version sure beats permanent deletion of a file I was just trying to read and print without modifying. 
Has somenoe told wizards about this? I think it's a major flaw, considering we are paying for this kind of systems to work correctly.
For some perspective, it's not like people haven't had characters randomly disappear BEFORE Silverlight 5 was released.  It's happened to a lot of people.  I'm a bit suspicious that it has anything to do with Silverlight 5 at all, but it certainly seems possible, even likely. 

So I haven't upgraded yet, but I wouldn't have anyway since I have no need at this point.  I would normally advise people not to upgrade anyway at this point, regardless of what's going on with the CB.  And it never hurts to export backup copies of your characters every once in a while - I've been doing that every so often, maybe once every six weeks, ever since the online CB was released.  If I upgrade to Silverlight 5 I'll be sure to make backups much more often, just in case.  In a way, I'm kinda glad we're limited to 20 characters ... makes backing up faster, haha.

OD&D, 1E and 2E challenged the player. 3E challenged the character, not the player. Now 4E takes it a step further by challenging a GROUP OF PLAYERS to work together as a TEAM. That's why I love 4E.

"Your ability to summon a horde of celestial superbeings at will is making my ... BMX skills look a bit redundant."

"People treat their lack of imagination as if it's the measure of what's silly. Which is silly." - Noon

"Challenge" is overrated.  "Immersion" is usually just a more pretentious way of saying "having fun playing D&D."

"Falling down is how you grow.  Staying down is how you die.  It's not what happens to you, it's what you do after it happens.”

Now I don't have SL5 yet but the way I see it there are two seperate issues here:

1.  CB crashing constantly after installing SL5.

2.  Characters sometimes disappearing after CB crashes.

And sometimes issue one can lead to issue two.

How many people besides the OP are really experiencing issue one?  I haven't upgraded and don't intend to so I can't say I have.  Is this problem happening to EVERYONE who upgrades to SL5, or just some people under some circumstances?  Is there anyone who uses the CB with SL5 that is seeing it work nominally?

Regarding issue two, that's been happening for a long time.  WoTC needs to figure out a way to keep characters from disappearing from their DB due to crashes in the CB, that's for sure.  I also have never experienced this, nor do I know anyone who has except for some folks on these boards who have reported it, and CB has crashed on me many times - never lost a character though.  I'm sure it happens sometimes but I just don't know how frequent it is, and that will determine how high a priority WoTC gives it.

So I guess the moral of the story is if you're running into problems detail everything you can and submit a bug report.  Help WoTC to identify and fix the issue.

OD&D, 1E and 2E challenged the player. 3E challenged the character, not the player. Now 4E takes it a step further by challenging a GROUP OF PLAYERS to work together as a TEAM. That's why I love 4E.

"Your ability to summon a horde of celestial superbeings at will is making my ... BMX skills look a bit redundant."

"People treat their lack of imagination as if it's the measure of what's silly. Which is silly." - Noon

"Challenge" is overrated.  "Immersion" is usually just a more pretentious way of saying "having fun playing D&D."

"Falling down is how you grow.  Staying down is how you die.  It's not what happens to you, it's what you do after it happens.”

Now I don't have SL5 yet but the way I see it there are two seperate issues here:

1.  CB crashing constantly after installing SL5.

2.  Characters sometimes disappearing after CB crashes.

And sometimes issue one can lead to issue two.

How many people besides the OP are really experiencing issue one?  I haven't upgraded and don't intend to so I can't say I have.  Is this problem happening to EVERYONE who upgrades to SL5, or just some people under some circumstances?  Is there anyone who uses the CB with SL5 that is seeing it work nominally?

Regarding issue two, that's been happening for a long time.  WoTC needs to figure out a way to keep characters from disappearing from their DB due to crashes in the CB, that's for sure.  I also have never experienced this, nor do I know anyone who has except for some folks on these boards who have reported it, and CB has crashed on me many times - never lost a character though.  I'm sure it happens sometimes but I just don't know how frequent it is, and that will determine how high a priority WoTC gives it.

So I guess the moral of the story is if you're running into problems detail everything you can and submit a bug report.  Help WoTC to identify and fix the issue.

So I'm definitely not the only person who experiences issue one, but it's actually testable. I have a machine with SL5 installed and a machine with SL4 installed. I have the problems on the machine with SL5, which only started after I installed it I might add, and I have no problems on the machine without.

But you've got a point about #2. It does seem as though if the character fails to load (crash on load) the CBs response is to delete the character. It wouldn't be shocking to me to discover that was a pre SL5 issue. It's just that with SL5, the odds of the crash on load go up significantly.

I did already detail everything and submit a bug report. By "detail everything" I mean I actually submitted a MHT from Problem Steps Recorder, filled with screenshots and the actual text of the errors I was receiving. I actually even had the character delete happen while I was doing this, so I have recorded repros of both situations.

Wizard's response was ... muted. So I came on the forums, and yes did discover threads such as this:   community.wizards.com/go/thread/view/758... 
 
So I thought I would make a thread specifically warning people about this problem, and offering help where needed, and perhaps getting the attention of someone at Wizards.
I did already detail everything and submit a bug report. By "detail everything" I mean I actually submitted a MHT from Problem Steps Recorder, filled with screenshots and the actual text of the errors I was receiving. I actually even had the character delete happen while I was doing this, so I have recorded repros of both situations.

You, sir, rock.

OD&D, 1E and 2E challenged the player. 3E challenged the character, not the player. Now 4E takes it a step further by challenging a GROUP OF PLAYERS to work together as a TEAM. That's why I love 4E.

"Your ability to summon a horde of celestial superbeings at will is making my ... BMX skills look a bit redundant."

"People treat their lack of imagination as if it's the measure of what's silly. Which is silly." - Noon

"Challenge" is overrated.  "Immersion" is usually just a more pretentious way of saying "having fun playing D&D."

"Falling down is how you grow.  Staying down is how you die.  It's not what happens to you, it's what you do after it happens.”

Has somenoe told wizards about this? I think it's a major flaw, considering we are paying for this kind of systems to work correctly.



I game with one of the architects for CB on a bi weekly basis up here in Seattle.  Once I hit it, I reported it directly and he forwarded the report.  Beyond that, I don't know if it works for some people, or if there is any servicing plan.
Uninstalling V5 was as simple as dragging the plugin to the trash. It is in /library/internet plug-ins.

The problem is there is no V4 to be found to reinstall. It isn't available to download. Clicking on any download or install button on the MS site invariably leads to downloading the V5 installer. I will wait and see if I get another response, but Microsoft doesn't generally make older versions of their products available because doing so admits that there might be beings on this planet who find fault with the current version.  



Go to CNET.com. They still have version 4 of Siverlight. I was having your exact problem, but I'm fine now.

Okay, so I have this exact problem, only that my system won't let me install Silverlight 4, even after deleting all associated plug-in files, receipts, and application support files, even the hidden ones by using Terminal.  I closed activity, and tried installing SL4, but it STILL thinks that I have a copy of SL5 installed on my computer. ;_ ;

Before posting, why not ask yourself, What Would Wrecan Say?

IMAGE(http://images.onesite.com/community.wizards.com/user/marandahir/thumb/9ac5d970f3a59330212c73baffe4c556.png?v=90000)

A great man once said "If WotC put out boxes full of free money there'd still be people complaining about how it's folded." – Boraxe

I just installed SL5 and I experienced several "something went wrong" errors and a couple of characters are gone.  Only one really mattered, and I had a back up of him, but the others were NPC's.

Very annoying, and quite frankly, unprofessional of WOTC.

Edit:

Just downgraded to SL4 and everything is back to normal. 
Just encountered this bug. My roommate and I threw out out char sheets last week in preperation of leveling. Just went to print them. *poof* all gone. Just like my D&D insider subscription after this month runs out.

Nice work WOTC.
i just tried downloading the Silverlight 4 Runtime from the site in the first post but the builder keeps saying i need to get silverlight.
Same thing happened to me.  Loaded up stuff over on a friend's computer.  I come home to check up on the work and half my characters are gone.  I submitted a less than pleasant bug report.  It's pretty offensive after being forced to change from the offline CB to an online one with no storage for my characters on my end.  I mean, what the hell am I paying for? 
Same thing happened to me.  Loaded up stuff over on a friend's computer.  I come home to check up on the work and half my characters are gone.  I submitted a less than pleasant bug report.  It's pretty offensive after being forced to change from the offline CB to an online one with no storage for my characters on my end.  I mean, what the hell am I paying for? 


It's been there since the first update.  When you click "Load" on the main screen, you can then select a PC saved on their servers and click the "Export" button at the bottom.
Same thing happened to me.  Loaded up stuff over on a friend's computer.  I come home to check up on the work and half my characters are gone.  I submitted a less than pleasant bug report.  It's pretty offensive after being forced to change from the offline CB to an online one with no storage for my characters on my end.  I mean, what the hell am I paying for? 


It's been there since the first update.  When you click "Load" on the main screen, you can then select a PC saved on their servers and click the "Export" button at the bottom.



Well, Hell, I'm dumb.  If it were a snake it would have bit me.  I take back some of the things I said.

But my fury persists!  And that's my right as an American!
Hey,

Bumping this because it would've been more helpful to me if it'd been at the top.

Also, WotC, a complaint. This problem should be easily fixed, but for the period it isn't, it'd be really good to put a big warning at the top of the 'known issues' with the character builder referring to it. And, frankly, the sterling work that's been done in diagnosing the problem in this thread by members of the commuJnity is the sort of result I'd expect from an open-source project, not a piece of software I've paid for (admittedly, as part of a bundle containing many other useful features).

Yours,

JMH

 
I'm with Kare here.  The first thing I did was check the known issues list to make sure something was being done about it.  It has almost been a month since the OP started this thread.  In that time I would expect some progress on a fix, or at the very least an acknowledgement of the problem.  Puting the warning to stay with silverlight 4 on your known issues list could have saved a lot of people's characters. 
Hey,

Here is a presently-working link to a site offering downloads of Silverlight 4. I downloaded 4.0.60531.0 and installed it which has made the character builder work as well as it ever did. It doesn't seem to have caused any problems elsewhere on my machine - I'll post again if I find it has.

Instructions (windows only, sorry):

1. Open 'control panel', open 'programs'
2. Select 'Silverlight' and uninstall
3. Download silverlight 4.0.60531.0, possibly from here: www.oldapps.com/silverlight.php 
4. Install the silverlight 4.0.60531.0 .exe file
5. Restart web-browser
6. Character builder should work now!

Hope this is helpful,

Yours,


JMH 
Hey,

Here is a presently-working link to a site offering downloads of Silverlight 4. I downloaded 4.0.60531.0 and installed it which has made the character builder work as well as it ever did. It doesn't seem to have caused any problems elsewhere on my machine - I'll post again if I find it has.

Instructions (windows only, sorry):

1. Open 'control panel', open 'programs'
2. Select 'Silverlight' and uninstall
3. Download silverlight 4.0.60531.0, possibly from here: www.oldapps.com/silverlight.php 
4. Install the silverlight 4.0.60531.0 .exe file
5. Restart web-browser
6. Character builder should work now!

Hope this is helpful,

Yours,


JMH 

Also, www.silverlight.net/downloads there's a big section "Silverlight 4 (previous version)" that you can download it from. (Click "Silverlight 4 Runtime") This was mentioned earlier, in case anyone wants to get it from Microsoft direct.

But thanks for the instructions! Every little bit of advice helps.

Hopefully someone posts OSX instructions haha. 
Hey,

I tried that, actually, but the product version I actually got was 5.5 (?) 

I'm running Windows 7 with Chrome (though I also tried in an old version of Firefox). It did an autocheck of something (browser/OS) before letting me to the download page. Anyway, generally speaking it's preferable not to get these things from third-parties since some ill-intentioned person could upload anything in an .exe file and just give it the 'silverlight' filename. As I said, I'll report back if I detect any issues.

Yours,

JMH 
Is Silverlight 5 still wreaking havoc on the Character Builder? Firefox recently disabled Silverlight 4 for being "known to cause security and stability issues." I'm wondering if it's safe to update or if I should just enable and continue to run Silverlight 4.
RS: 60/60 CS: 60/60 RotS: 60/60 U:60/60 CotF: 60/60 BH: 60/60 A&E: 51/60 TFU: 53/60 LotF: 37/60 KotOR: 37/60 CW: 26/40 IE: 31/40 JA: 17/40 G@W: 7/40 DT: 7/40 Good trades with: Lily_Wan, creme_brule, suki_jedi_apprentice, Ephant_Mon
I'm still using Silverlight 4, but Netflix won't work on my computer anymore unless I install Silverlight 5. 

Can I safely transition over to Silverlight 5?

Before posting, why not ask yourself, What Would Wrecan Say?

IMAGE(http://images.onesite.com/community.wizards.com/user/marandahir/thumb/9ac5d970f3a59330212c73baffe4c556.png?v=90000)

A great man once said "If WotC put out boxes full of free money there'd still be people complaining about how it's folded." – Boraxe

Is this still an issue?  I came here wondering if there was a policy about deleting characters in the Builder, since I had a character vanish.  Then I read this thread and remembered a "Something Happened" error.

I am on Windows 7 and have recently re-installed Chrome so I will be on the latest Silverlight. 
I think I just encountered this bug, which I had thought was long since fixed. Yell
Sign In to post comments